Moving Carbonio to ...
 
Notifications
Clear all

Moving Carbonio to a different machine or partition

1 Posts
1 Users
0 Likes
44 Views
(@martin-i)
Joined: 1 month ago
Posts: 1
Topic starter  

I am an experianced Zimbra admininistrator, working with zimbra since 20 years.

An important task I had to  frequently was to move Zimbra from one machine to another in case the OS reached end of life or if a partition ran out of space. The was quite simple -  a silent install, mounting a clone of /opt/zimbra, install.sh, done.

 

I want to migrate to Carbonio, so I tested this important procedure. On a test machine I tried to sync /opt/zextra to a partition with

rsync -axHAWXS --numeric-ids --info=progress2 /opt/zextras  /mnt/

After mounting Carbonio started, but logins failed - "auth credentials have expired".

 

Setting a new password with zmprov sp worked with no error, bad had no effect. Creating a new user with zmprov ca the same. A reinstall with install_carbonio_ce_singleserver_ubuntu.sh after succesfully starts of the zimbra serices failes with different errors like

service-discover: error: setup of service-discover already performed, manually reset and try again.
gpg: decryption failed: Bad session key
tar: This does not look like a tar archive
tar: consul-acl-secret.json: Not found in archive
tar: Exiting with failure status due to previous errors
Insert the cluster credential password: service-discover: error: openpgp: incorrect key
Cannot access to bootstrap token
ERROR: role "carbonio_adm" already exists
ERROR: database "carbonio_adm" already exists
Database: 127.0.0.1:5432 user carbonio_adm
Check postgres connection: psql: FATAL ERROR (exit code 2).
(see EXIT STATUS section in psql man documentation)
psql: error: connection to server at "127.0.0.1", port 5432 failed: FATAL: password authentication failed for user "carbonio_adm"
connection to server at "127.0.0.1", port 5432 failed: FATAL: password authentication failed for user "carbonio_adm"
Database: 127.0.0.1:5432 | User: carbonio_adm

I never set a password during installation which Carbonio is now asking for.

What is a safe procedure to move /opt/zextras to a new machine or disk?

Thank you, martin


   
Quote