Hi Masters!
I successfully installed the Zextras software, and everything worked perfectly until I configured the certificate for the mail server. After the configuration, the page failed to load, and the following services did not start:
- carbonio-files
- carbonio-tasks
- carbonio-ws-collaboration
- carbonio-message-dispatcher-auth
After extensively searching through the log files, I discovered that the issue was related to the PostgreSQL configuration. Specifically, the "Catalog Address" was listening only on the 127.0.0.1 address. Once I expanded this—adding my own private/public address—it worked perfectly.
Solution with IP address example:
# postgresql.conf
listen_addresses = 'localhost,192.168.123.4'# pg_hba.conf
host all all 127.0.0.1/32 scram-sha-256
host all all 192.168.123.4/32 scram-sha-256sudo systemctl restart postgresql
OS: Ubuntu Server 24.04 LTS
Zextras: Carbonio Release 26.6.2 (CE)
I hope this has helped the developers with their work. 🙂
Regadrs: DrCyberg
