proxy not working a...
 
Notifications
Clear all

[Solved] proxy not working after adding virtualhost certificate

4 Posts
3 Users
1 Reactions
297 Views
(@manu67a)
Joined: 4 months ago
Posts: 2
Topic starter  

Hi All,

 

I'm currently in the process of migrating a long running zimbra server to Carbonio CE.

I have successfully configured the new server and wanted to migrate a first domain to Carbonio.

Domain and users are there and wanted to add the lets encrypt cert.

DNS was modified prior to the request

Request went fine then came the time to restart the proxy and I have the following error:

Starting proxy...nginx: [warn] conflicting server name "mail.domain.aaa" on 0.0.0.0:443, ignored
nginx: [warn] conflicting server name "mail.domain.aaa" on 0.0.0.0:6071, ignored
nginx: [emerg] conflicting parameter "mail.domain.aaa" in /opt/zextras/conf/nginx/includes/nginx.conf.map.crt:3

Line 3 in the file is just a copy of line 1 and line 2 is empty.

I don't understand why I have 2 identical entries.

Any pointer or further diagnotic would be appreciated.

Many thanks.


   
Quote
(@rwebb616)
Joined: 8 years ago
Posts: 56
 

I know this is somewhat old, but I too am having the same issue .. Problem is I don't understand the interface in the admin panel.  You have "Virtual Hosts" under each domain name but it seems certificates should be a global server wide setting.  I tried both ways to enter the domains that my server is handling and when I did it on the main domain for all the virtual domains the certificate request worked fine and the certs were issued but when I restart the proxy I get the same results as the OP but it gives me more domains listed. 

Not sure how to fix this so that I can get the proxy running again.  The proxy refuses to start in the is situation.

Rich


   
ReplyQuote
(@rwebb616)
Joined: 8 years ago
Posts: 56
 

If anyone else encounters this, I used the zmprov command to manually delete the virtual hostnames that I had previously added in the gui by entering: 

zmprov md example.com -zimbraVirtualHostname <hostname to delete>

Then after they were deleted I simply restarted the proxy:

zmproxyctl restart

Rich


   
manu67a reacted
ReplyQuote
(@daddycool)
Joined: 6 months ago
Posts: 7
 

@rwebb616 I messed up a bit so this was a life saver, thank you! 🙂


   
ReplyQuote