Notifications
Clear all

[Solved] Unable to install Carbonio CE .......


phoenix
(@phoenix)
Joined: 8 years ago
Posts: 50
Topic starter  

I've just installed a Ubuntu 20.40.4 LTS Server and tried to get Carbonio CE installed, unfortunately it's thrown several errors as shown below:

root@mail03:~# apt install carbonio-ce
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
carbonio-auth-ui : Depends: jq but it is not installable
carbonio-calendars-ui : Depends: jq but it is not installable
carbonio-contacts-ui : Depends: jq but it is not installable
carbonio-core : Depends: fontconfig but it is not installable
Depends: libidn11 but it is not installable
Depends: libperl5.30 but it is not installable
Depends: libsocket6-perl but it is not installable
Depends: pax but it is not installable
Depends: pending-setups but it is not going to be installed
Depends: resolvconf but it is not installable
Depends: sysstat but it is not installable
Depends: unzip but it is not installable
carbonio-error-reporter-ui : Depends: jq but it is not installable
carbonio-mails-ui : Depends: jq but it is not installable
carbonio-mariadb : Depends: libcrack2 but it is not installable
Depends: libgnutlsxx28 but it is not installable
Depends: libsnappy1v5 but it is not installable
carbonio-mta : Depends: carbonio-amavisd but it is not going to be installed
Depends: sqlite3 but it is not installable
carbonio-proxy : Depends: sqlite3 but it is not installable
carbonio-rrdtool : Depends: libpango-1.0-0 but it is not installable
carbonio-shell-ui : Depends: jq but it is not installable
E: Unable to correct problems, you have held broken packages.

 

I don't have any experience of using Ubuntu so my question is, have I missed something obvious. It also seems that 'libidn11' is missing from this install but ' libidn12' is available.

Perhaps I'd be better waiting for a Rocky Linux build as I'm more comfortable with that.


Quote
phoenix
(@phoenix)
Joined: 8 years ago
Posts: 50
Topic starter  

This was resolved by a reinstall although I don't think I did anything different than the last time I tried. It seems to be all OK (although I'm still going to go with a RHEL version when it's released) and I'm just in the process of installing Carbonio-CE. 🙂


ReplyQuote
stefanodavid
(@stefanodavid)
Joined: 10 months ago
Posts: 7
 

@phoenix, we are in the process of rewriting the installation guide to avoid using the carbonio-ce meta-package, which may sometimes lead to unwanted and unfortunate situations. Those errors mean that dependencies could not be solved, probably you had to update the packages list and and upgrade the system prior to the Carbonio CE installation. Sorry for getting back late, but we're quite busy at the moment, please bear with us! 🙂


ReplyQuote