Carbonio CE Upgrade...
 
Notifications
Clear all

[Solved] Carbonio CE Upgrade from 23.4.0 to 23.5.0. E-mail subject add *** UNCHECKED ***

6 Posts
4 Users
3 Likes
1,336 Views
(@iliapro)
Joined: 11 months ago
Posts: 5
Topic starter  

Hello!

Today updated Carbonio CE from 23.4.0 to 23.5.0 on UBUNTU 20.04.

After the update, UNCHECKED is added to all email subject. 

I guess that the problem is in the antivirus check of the e-mail.

zextras@mail:~$ zmcontrol status
Host mail.test.com
amavis Running
antispam Running
antivirus Running
directory-server Running
mailbox Running
memcached Running
mta Running
opendkim Running
proxy Running
service webapp Running
service-discover Running
stats Running
config service Running
zextras@mail:~$ zmclamdctl status
clamd is running.

Tell me, what else and where can I look to determine the problem in the antivirus check or in something else?

Best regards,

Ilya Prochorov.


   
Quote
(@iliapro)
Joined: 11 months ago
Posts: 5
Topic starter  

Thanks for the quick response to the issue. Fixed carbonio-clamav package. It needs to be updated in the standard way.

I will also write that if you are using a local clamav mirror, then you need to do the following:

su - zextras
zmprov mcf zimbraClamAVDatabaseMirror adress-to-local-mirror
zmcontrol restart

Best regards,

Ilya Prokhorov

This post was modified 11 months ago 2 times by IliaPro

   
ReplyQuote
(@hwall)
Joined: 10 months ago
Posts: 2
 

@iliapro Didn't help in my case. I've been trying to remove this garbage from the subject of the letter for a week now. Looks like I'll have to send this mailer to hell.


   
ReplyQuote
(@anahuac)
Joined: 10 months ago
Posts: 304
 

For me what really worked was edit conf/amavisd.conf.in, go to line 450 and replace that section.... replacing

  ['ClamAV-remote-stream',
   \&ask_daemon, [
     "{}/*",
     [  
       'clamd:127.78.0.17:20000'
     ],
   ],
   qr/\bOK$/m, qr/\bFOUND$/m,
   qr/^.*?: (?!Infected Archive)(.*) FOUND$/m
 ],

 

by

 

['ClamAV-clamd',
  \&ask_daemon, ["CONTSCAN {}\n", '/opt/zextras/data/clamav/clamav.sock'],
  qr/\bOK$/m, qr/\bFOUND$/m,
  qr/^.*?: (?!Infected Archive)(.*) FOUND$/m ],

And restarting amavis


   
ReplyQuote
(@anahuac)
Joined: 10 months ago
Posts: 304
 

Digging deeper I found the real problem and the solution above became justa a workaround.

The step where you have to run "pending-setups -a" gave me a minor error and I didn't didn't gave it much attention. Well I should have. IMHO the alert about it is not clear enough to make clear how serious it is, so my suggestion to devs is to make it really visible.

The error happen because the package "python3-request" is missing... and it should be installed by Carbonio as a dependency but it's not.

So:

1 - undo the workaround I mentioned in my previous post on conf/amavisd.conf.in

2 - apt install python3-request

3 - pending-setups -a

4 - zmcontrol restart

Regards


   
ReplyQuote
We-Proud
(@we-proud)
Joined: 2 years ago
Posts: 12
 

Same problem and already resolved.

Mine,

As root>

1. apt upgrade python

2. apt-get install python3-pip

3. apt install clamav

4.freshclam

login as zextras>

5. zmcontrol restart

Regards,


   
ReplyQuote