Failed SSL Cert req...
 
Notifications
Clear all

[Solved] Failed SSL Cert request from Admin UI

32 Posts
6 Users
1 Likes
1,191 Views
(@zottel)
Joined: 3 months ago
Posts: 17
 

Hi,

I have the same problem on my freshly installed Carbonio 23.12. The server is not listening on port 80.

zimbraReverseProxyAvailableLookupTargets looks good, zimbraReverseProxyMailMode is set to redirect. (That's correct on a single server installation, right?) I didn't have to change these settings, but ran zmproxyconfgen anyway, which didn't throw any errors or warnings.

zmproxyctl restart says

Stopping proxy...nginx: [warn] conflicting server name "carbonio.zottel.net" on 0.0.0.0:443, ignored
done.
Starting proxy...nginx: [warn] conflicting server name "carbonio.zottel.net" on 0.0.0.0:443, ignored
done.

Looking through the nginx configs in /opt/zextras/conf/nginx/includes/, I noticed that the only files where a "listen 80" directive is issued are nginx.conf.web.http and nginx.conf.web.http.default, but those are not included anywhere in my configuration. The corresponding include lines in nginx.conf.web are commented out.

Any ideas what could be wrong?

Thanks, Christian


   
ReplyQuote
(@zottel)
Joined: 3 months ago
Posts: 17
 

Ah, sorry, it was my problem, I had two misunderstandings in the documentation:

First, I didn't realize that the prov gacf command was a global setting whereas the ms command was a setting local to the server. I thought that if gacf returned redirect, everything must be correct for my server. gs, however, returned https, so that was the problem.

Second, I wasn't sure if my single server system qualified as a "proxy node" as described in the documention, and if the step to delete zimbraReverseProxyMailMode on the proxy nodes would have to executed on my server. When I did that, it worked.


   
ReplyQuote
Page 3 / 3