Notifications
Clear all

Upgrade to P24 failes


joob77
(@joob77)
Joined: 1 year ago
Posts: 5
Topic starter  

Hi,

I have a Zimbra Zextras Edition installation of version 9.0.0_ZEXTRAS_20211118 (build 20211115190340).

I'm trying to install P24 as an upgrade to the version mentioned above.

The error I'm getting is: ...Unable to download packages from repository. System is not modified.

My Zimbra installation runs on Ubuntu 18.04: 4.15.0-187-generic #198-Ubuntu SMP Tue Jun 14 0351 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

I've updated with the latest Ubuntu patches. And I've cleared the apt cache, checked DNS setting in \etc\resolvconf

 

I keep getting this error: ...Unable to download packages from repository. System is not modified.

I've checked the log: /tmp/install.log.PuKIOYpw. And it states: 

======

W: --force-yes is deprecated, use one of the options starting with --allow instead.
E: Failed to fetch https://repo.zimbra.com/apt/90/pool/zimbra/z/zimbra-clamav/zimbra-clamav_0.103.3-1zimbra8.8b3.18.04_amd64.deb 403 Forbidden [IP: 65.9.86.93 443]
E: Failed to fetch https://repo.zimbra.com/apt/90/pool/zimbra/z/zimbra-clamav/zimbra-clamav-lib_0.103.3-1zimbra8.8b3.18.04_amd64.deb 403 Forbidden [IP: 65.9.86.93 443]
E: Failed to fetch https://repo.zimbra.com/apt/90/pool/zimbra/z/zimbra-openssl/zimbra-openssl_1.1.1n-1zimbra8.7b4.18.04_amd64.deb 403 Forbidden [IP: 65.9.86.93 443]
E: Failed to fetch https://repo.zimbra.com/apt/90/pool/zimbra/z/zimbra-openssl/zimbra-openssl-lib_1.1.1n-1zimbra8.7b4.18.04_amd64.deb 403 Forbidden [IP: 65.9.86.93 443]
E: Failed to fetch https://repo.zimbra.com/apt/90/pool/zimbra/z/zimbra-openjdk/zimbra-openjdk_17.0.2-1zimbra8.8b1.18.04_amd64.deb 403 Forbidden [IP: 65.9.86.93 443]
E: Failed to fetch https://repo.zimbra.com/apt/90/pool/zimbra/z/zimbra-core-components/zimbra-core-components_3.0.12-1zimbra8.8b1.18.04_all.deb 403 Forbidden [IP: 65.9.86.93 443]
E: Failed to fetch https://repo.zimbra.com/apt/90/pool/zimbra/z/zimbra-ldap-components/zimbra-ldap-components_2.0.6-1zimbra8.8b1.18.04_all.deb 403 Forbidden [IP: 65.9.86.93 443]
E: Failed to fetch https://repo.zimbra.com/apt/90/pool/zimbra/z/zimbra-mta-components/zimbra-mta-components_1.0.15-1zimbra8.8b1.18.04_all.deb 403 Forbidden [IP: 65.9.86.93 443]
E: Failed to fetch https://repo.zimbra.com/apt/90/pool/zimbra/z/zimbra-spell-components/zimbra-spell-components_2.0.8-1zimbra8.8b1.18.04_all.deb 403 Forbidden [IP: 65.9.86.93 443]
E: Some files failed to download

======

 

It seems the installer wants to download sources from Zimbra itself... How do I correct this? Is there a way for me to work around this?

 

Help is greatly appreciated!

Many thanks in advance.

Greetz,

Joost Brenters

The Netherlands


Quote
Md. Shariful Islam
(@shariful-islam)
Moderator
Joined: 1 month ago
Posts: 14
 

@joob77

Hi,

There seems to be a change in Zimbra dependencies recently, so the last Zimbra 9 build by Zextras is no longer installing.

The error reported in the logs is:

The following packages have unmet dependencies:
 zimbra-core-components : Depends: zimbra-osl (>= 2.0.0-1zimbra9.0b1.20.04) but it is not going to be installed
W: --force-yes is deprecated, use one of the options starting with --allow instead.
E: Unable to correct problems, you have held broken packages.

We're investigating this, in the meantime, I suggest avoiding installing or upgrading production servers.

We'll provide news and, possibly, a solution ASAP.

Thanks.


ReplyQuote
joob77
(@joob77)
Joined: 1 year ago
Posts: 5
Topic starter  

Hello,

Thank you for your reply. I’ll wait for a solution to be available.

 

sincerely,

Joost Brenters

The Netherlands 


ReplyQuote
phoenix
(@phoenix)
Joined: 8 years ago
Posts: 50
 

In case it hasn't been mentioned, Zimbra has taken all the repos offline instead of just removing the failed upgrades.


ReplyQuote
joob77
(@joob77)
Joined: 1 year ago
Posts: 5

ReplyQuote