Notifications
Clear all

FAIL to install to AlmaLinux8.5, but success to install to CENTOS8.4


dominix
(@dominix)
Joined: 9 years ago
Posts: 28
Topic starter  

Hi everyone around, 

I've made some test on Zimbra9 to verify upgradability of your actual system in 8.8.15.  As I plan to keep RHEL equivalent I have tested an install with Almalinux, which have my preference. 

I have converted 2 install of ZIMBRA 8.8.15 on CentOS8 to AlmaLinux8, it works well and it upgrade well to the last patch. 

But when it comes to install Zimbra9 I got errors at install time saying  there is unresolved dependencies. It looks like the ./install.sh is not able to add the Zimbra repository, whereas it doesn't occurs with Centos8. 

Has Synacor recommend not to use Centos8-stream an encourage to switch to some real full compatible RHEL8 could you ensure the build will install correctly in AlmaLinux8 ?

thank for your commitment.


Quote
dani
 dani
(@dani)
Joined: 9 months ago
Posts: 12
 

The modification for AlmaLinux is simple, see my patch here https://github.com/Zimbra/zm-build/pull/194/commits/8c5b69b69631d91db9286ad54d4e46936f30c87b

This post was modified 6 months ago by dani

ReplyQuote
dominix
(@dominix)
Joined: 9 years ago
Posts: 28
Topic starter  
Posted by: @dani

The modification for AlmaLinux is simple, see my patch here https://github.com/Zimbra/zm-build/pull/194/commits/8c5b69b69631d91db9286ad54d4e46936f30c87b

Nice ! I will try it soon.


ReplyQuote
dominix
(@dominix)
Joined: 9 years ago
Posts: 28
Topic starter  

By the way I did not succeed to convert the CEntos8 to AlmaLinux after Zimbra9 install.

Run dnf distro-sync -y. Exit code: 1 ERROR

Erreur :
Problème 1: le paquet zimbra-mbox-service-9.0.0.1635328066-1.r8.x86_64 nécessite zimbra-common-core-jar >= 9.0.0.1635328066-1.r8, mais aucun fournisseur ne peut être installé
- zimbra-common-core-jar-9.0.0.1635328066-1.r8.x86_64 n’appartient pas à un dépôt distupgrade
- problème avec le paquet installé zimbra-mbox-service-9.0.0.1635328066-1.r8.x86_64
Problème 2: le paquet zimbra-mbox-service-9.0.0.1635328066-1.r8.x86_64 nécessite zimbra-mbox-war >= 9.0.0.1635328066-1.r8, mais aucun fournisseur ne peut être installé
- le paquet zimbra-store-9.0.0_ZEXTRAS_20211118.RHEL8_64-20211115190513.x86_64 nécessite zimbra-mbox-service, mais aucun fournisseur ne peut être installé
- zimbra-mbox-war-9.0.0.1635328066-1.r8.x86_64 n’appartient pas à un dépôt distupgrade
- problème avec le paquet installé zimbra-store-9.0.0_ZEXTRAS_20211118.RHEL8_64-20211115190513.x86_64
Problème 3: le paquet zimbra-mbox-service-9.0.0.1635328066-1.r8.x86_64 nécessite zimbra-common-core-jar >= 9.0.0.1635328066-1.r8, mais aucun fournisseur ne peut être installé

ReplyQuote
dominix
(@dominix)
Joined: 9 years ago
Posts: 28
Topic starter  

@dani   Thanks, it works well !

zimbra9 ready on Almalinux8.5


ReplyQuote